Austin Schuh | 8611071 | 2022-09-16 15:40:54 -0700 | [diff] [blame] | 1 | Submodule crt/aws-crt-cpp contains modified content |
| 2 | Submodule crt/aws-c-cal contains modified content |
| 3 | diff --git a/crt/aws-crt-cpp/crt/aws-c-cal/source/unix/openssl_platform_init.c b/crt/aws-crt-cpp/crt/aws-c-cal/source/unix/openssl_platform_init.c |
| 4 | index 761455b..fc434ba 100644 |
| 5 | --- a/crt/aws-crt-cpp/crt/aws-c-cal/source/unix/openssl_platform_init.c |
| 6 | +++ b/crt/aws-crt-cpp/crt/aws-c-cal/source/unix/openssl_platform_init.c |
James Kuszmaul | b0931ac | 2023-01-24 14:23:13 -0800 | [diff] [blame^] | 7 | @@ -37,7 +37,7 @@ struct openssl_evp_md_ctx_table *g_aws_openssl_evp_md_ctx_table = NULL; |
Austin Schuh | 8611071 | 2022-09-16 15:40:54 -0700 | [diff] [blame] | 8 | /* 1.1 */ |
James Kuszmaul | b0931ac | 2023-01-24 14:23:13 -0800 | [diff] [blame^] | 9 | extern HMAC_CTX *HMAC_CTX_new(void) __attribute__((weak, used)); |
| 10 | extern void HMAC_CTX_free(HMAC_CTX *) __attribute__((weak, used)); |
| 11 | -extern int HMAC_CTX_reset(HMAC_CTX *) __attribute__((weak, used)); |
| 12 | +//extern int HMAC_CTX_reset(HMAC_CTX *) __attribute__((weak, used)); |
| 13 | |
Austin Schuh | 8611071 | 2022-09-16 15:40:54 -0700 | [diff] [blame] | 14 | /* 1.0.2 */ |
James Kuszmaul | b0931ac | 2023-01-24 14:23:13 -0800 | [diff] [blame^] | 15 | extern void HMAC_CTX_init(HMAC_CTX *) __attribute__((weak, used)); |
| 16 | @@ -46,7 +46,7 @@ extern void HMAC_CTX_cleanup(HMAC_CTX *) __attribute__((weak)) __attribute__((us |
Austin Schuh | 8611071 | 2022-09-16 15:40:54 -0700 | [diff] [blame] | 17 | /* common */ |
James Kuszmaul | b0931ac | 2023-01-24 14:23:13 -0800 | [diff] [blame^] | 18 | extern int HMAC_Update(HMAC_CTX *, const unsigned char *, size_t) __attribute__((weak, used)); |
| 19 | extern int HMAC_Final(HMAC_CTX *, unsigned char *, unsigned int *) __attribute__((weak, used)); |
| 20 | -extern int HMAC_Init_ex(HMAC_CTX *, const void *, int, const EVP_MD *, ENGINE *) __attribute__((weak, used)); |
| 21 | +//extern int HMAC_Init_ex(HMAC_CTX *, const void *, int, const EVP_MD *, ENGINE *) __attribute__((weak, used)); |
| 22 | |
Austin Schuh | 8611071 | 2022-09-16 15:40:54 -0700 | [diff] [blame] | 23 | /* libcrypto 1.1 stub for init */ |
| 24 | static void s_hmac_ctx_init_noop(HMAC_CTX *ctx) { |
Austin Schuh | 8611071 | 2022-09-16 15:40:54 -0700 | [diff] [blame] | 25 | Submodule crt/s2n contains modified content |