Austin Schuh | 8611071 | 2022-09-16 15:40:54 -0700 | [diff] [blame] | 1 | Submodule crt/aws-crt-cpp contains modified content |
| 2 | Submodule crt/aws-c-cal contains modified content |
| 3 | diff --git a/crt/aws-crt-cpp/crt/aws-c-cal/source/unix/openssl_platform_init.c b/crt/aws-crt-cpp/crt/aws-c-cal/source/unix/openssl_platform_init.c |
| 4 | index 761455b..fc434ba 100644 |
| 5 | --- a/crt/aws-crt-cpp/crt/aws-c-cal/source/unix/openssl_platform_init.c |
| 6 | +++ b/crt/aws-crt-cpp/crt/aws-c-cal/source/unix/openssl_platform_init.c |
| 7 | @@ -34,7 +34,7 @@ struct openssl_evp_md_ctx_table *g_aws_openssl_evp_md_ctx_table = NULL; |
| 8 | /* 1.1 */ |
| 9 | extern HMAC_CTX *HMAC_CTX_new(void) __attribute__((weak)) __attribute__((used)); |
| 10 | extern void HMAC_CTX_free(HMAC_CTX *) __attribute__((weak)) __attribute__((used)); |
| 11 | -extern int HMAC_CTX_reset(HMAC_CTX *) __attribute__((weak)) __attribute__((used)); |
| 12 | +//extern int HMAC_CTX_reset(HMAC_CTX *) __attribute__((weak)) __attribute__((used)); |
| 13 | |
| 14 | /* 1.0.2 */ |
| 15 | extern void HMAC_CTX_init(HMAC_CTX *) __attribute__((weak)) __attribute__((used)); |
| 16 | @@ -43,8 +43,8 @@ extern void HMAC_CTX_cleanup(HMAC_CTX *) __attribute__((weak)) __attribute__((us |
| 17 | /* common */ |
| 18 | extern int HMAC_Update(HMAC_CTX *, const unsigned char *, size_t) __attribute__((weak)) __attribute__((used)); |
| 19 | extern int HMAC_Final(HMAC_CTX *, unsigned char *, unsigned int *) __attribute__((weak)) __attribute__((used)); |
| 20 | -extern int HMAC_Init_ex(HMAC_CTX *, const void *, int, const EVP_MD *, ENGINE *) __attribute__((weak)) |
| 21 | -__attribute__((used)); |
| 22 | +//extern int HMAC_Init_ex(HMAC_CTX *, const void *, int, const EVP_MD *, ENGINE *) __attribute__((weak)) |
| 23 | +//__attribute__((used)); |
| 24 | |
| 25 | /* libcrypto 1.1 stub for init */ |
| 26 | static void s_hmac_ctx_init_noop(HMAC_CTX *ctx) { |
| 27 | @@ -393,9 +393,9 @@ void aws_cal_platform_init(struct aws_allocator *allocator) { |
| 28 | } |
| 29 | } |
| 30 | |
| 31 | - if (!CRYPTO_get_id_callback()) { |
| 32 | - CRYPTO_set_id_callback(s_id_fn); |
| 33 | - } |
| 34 | + //if (!CRYPTO_get_id_callback()) { |
| 35 | + //CRYPTO_set_id_callback(s_id_fn); |
| 36 | + //} |
| 37 | } |
| 38 | |
| 39 | void aws_cal_platform_clean_up(void) { |
| 40 | @@ -408,9 +408,9 @@ void aws_cal_platform_clean_up(void) { |
| 41 | aws_mem_release(s_libcrypto_allocator, s_libcrypto_locks); |
| 42 | } |
| 43 | |
| 44 | - if (CRYPTO_get_id_callback() == s_id_fn) { |
| 45 | - CRYPTO_set_id_callback(NULL); |
| 46 | - } |
| 47 | + //if (CRYPTO_get_id_callback() == s_id_fn) { |
| 48 | + //CRYPTO_set_id_callback(NULL); |
| 49 | + //} |
| 50 | } |
| 51 | #if !defined(__GNUC__) || (__GNUC__ >= 4 && __GNUC_MINOR__ > 1) |
| 52 | # pragma GCC diagnostic pop |
| 53 | Submodule crt/s2n contains modified content |
| 54 | diff --git a/crt/aws-crt-cpp/crt/s2n/utils/s2n_asn1_time.c b/crt/aws-crt-cpp/crt/s2n/utils/s2n_asn1_time.c |
| 55 | index 84dbc6df..d3566b81 100755 |
| 56 | --- a/crt/aws-crt-cpp/crt/s2n/utils/s2n_asn1_time.c |
| 57 | +++ b/crt/aws-crt-cpp/crt/s2n/utils/s2n_asn1_time.c |
| 58 | @@ -46,7 +46,7 @@ typedef enum parser_state { |
| 59 | } parser_state; |
| 60 | |
| 61 | static inline long get_gmt_offset(struct tm *t) { |
| 62 | -#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__ANDROID__) || defined(ANDROID) || defined(__APPLE__) && defined(__MACH__) |
| 63 | +#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__ANDROID__) || defined(ANDROID) || defined(__APPLE__) && defined(__MACH__) || defined(__USE_MISC) |
| 64 | return t->tm_gmtoff; |
| 65 | #else |
| 66 | return t->__tm_gmtoff; |
| 67 | diff --git a/crt/aws-crt-cpp/crt/s2n/utils/s2n_init.c b/crt/aws-crt-cpp/crt/s2n/utils/s2n_init.c |
| 68 | index 0f79f959..ae8122fb 100644 |
| 69 | --- a/crt/aws-crt-cpp/crt/s2n/utils/s2n_init.c |
| 70 | +++ b/crt/aws-crt-cpp/crt/s2n/utils/s2n_init.c |
| 71 | @@ -45,7 +45,7 @@ int s2n_init(void) |
| 72 | GUARD_POSIX(s2n_security_policies_init()); |
| 73 | GUARD_POSIX(s2n_config_defaults_init()); |
| 74 | GUARD_POSIX(s2n_extension_type_init()); |
| 75 | - GUARD_AS_POSIX(s2n_pq_init()); |
| 76 | + //GUARD_AS_POSIX(s2n_pq_init()); |
| 77 | |
| 78 | S2N_ERROR_IF(atexit(s2n_cleanup_atexit) != 0, S2N_ERR_ATEXIT); |
| 79 | |
| 80 | diff --git a/crt/aws-crt-cpp/crt/aws-c-common/include/aws/common/private/lookup3.inl b/crt/aws-crt-cpp/crt/aws-c-common/include/aws/common/private/lookup3.inl |
| 81 | index 0f79f959..ae8122fb 100644 |
| 82 | --- a/crt/aws-crt-cpp/crt/aws-c-common/include/aws/common/private/lookup3.inl |
| 83 | +++ b/crt/aws-crt-cpp/crt/aws-c-common/include/aws/common/private/lookup3.inl |
| 84 | @@ -533,7 +533,7 @@ |
| 85 | * "CPROVER check pop". The masking trick does make the hash noticably |
| 86 | * faster for short strings (like English words). |
| 87 | */ |
| 88 | -#ifndef VALGRIND |
| 89 | +#if !defined(VALGRIND) && !__has_feature(address_sanitizer) && !__has_feature(memory_sanitizer) |
| 90 | #ifdef CBMC |
| 91 | # pragma CPROVER check push |
| 92 | # pragma CPROVER check disable "pointer" |