James Kuszmaul | 82f6c04 | 2021-01-17 11:30:16 -0800 | [diff] [blame] | 1 | #!/usr/bin/make -f |
| 2 | # -*- makefile -*- |
| 3 | # Sample debian/rules that uses debhelper. |
| 4 | # This file was originally written by Joey Hess and Craig Small. |
| 5 | # As a special exception, when this file is copied by dh-make into a |
| 6 | # dh-make output file, you may use that output file without restriction. |
| 7 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
| 8 | |
| 9 | # Uncomment this to turn on verbose mode. |
| 10 | #export DH_VERBOSE=1 |
| 11 | |
| 12 | |
| 13 | EXTRA_CFLAGS:="$(shell dpkg-buildflags --get CFLAGS | sed -e 's/-O2//')" |
| 14 | EXTRA_LFLAGS:="$(shell dpkg-buildflags --get LDFLAGS) -Wl,-soname,libre.so" |
| 15 | |
| 16 | |
| 17 | configure: configure-stamp |
| 18 | configure-stamp: |
| 19 | dh_testdir |
| 20 | # Add here commands to configure the package. |
| 21 | |
| 22 | touch configure-stamp |
| 23 | |
| 24 | build: build-stamp |
| 25 | build-stamp: configure-stamp |
| 26 | dh_testdir |
| 27 | |
| 28 | # Add here commands to compile the package. |
| 29 | $(MAKE) RELEASE=1 \ |
| 30 | EXTRA_CFLAGS=$(EXTRA_CFLAGS) \ |
| 31 | EXTRA_LFLAGS=$(EXTRA_LFLAGS) |
| 32 | |
| 33 | touch $@ |
| 34 | |
| 35 | clean: |
| 36 | dh_testdir |
| 37 | dh_testroot |
| 38 | rm -f build-stamp configure-stamp |
| 39 | |
| 40 | # Add here commands to clean up after the build process. |
| 41 | $(MAKE) clean |
| 42 | |
| 43 | dh_clean |
| 44 | |
| 45 | install: build |
| 46 | dh_testdir |
| 47 | dh_testroot |
| 48 | dh_prep |
| 49 | dh_installdirs |
| 50 | |
| 51 | # Add here commands to install the package into debian/tmp |
| 52 | mkdir $(CURDIR)/debian/tmp |
| 53 | $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
| 54 | |
| 55 | dh_movefiles |
| 56 | |
| 57 | # Build architecture-independent files here. |
| 58 | binary-indep: build install |
| 59 | # We have nothing to do by default. |
| 60 | |
| 61 | # Build architecture-dependent files here. |
| 62 | binary-arch: build install |
| 63 | dh_testdir |
| 64 | dh_testroot |
| 65 | dh_installchangelogs |
| 66 | dh_installdocs |
| 67 | dh_installexamples |
| 68 | # dh_install |
| 69 | # dh_installmenu |
| 70 | # dh_installdebconf |
| 71 | # dh_installlogrotate |
| 72 | # dh_installemacsen |
| 73 | # dh_installpam |
| 74 | # dh_installmime |
| 75 | # dh_installinit |
| 76 | # dh_installcron |
| 77 | # dh_installinfo |
| 78 | dh_installman |
| 79 | dh_link |
| 80 | dh_strip |
| 81 | dh_compress |
| 82 | dh_fixperms |
| 83 | # dh_perl |
| 84 | # dh_python |
| 85 | dh_makeshlibs |
| 86 | dh_installdeb |
| 87 | dh_shlibdeps |
| 88 | dh_gencontrol |
| 89 | dh_md5sums |
| 90 | dh_builddeb |
| 91 | |
| 92 | build-arch: build |
| 93 | |
| 94 | build-indep: build |
| 95 | |
| 96 | binary: binary-indep binary-arch |
| 97 | .PHONY: build clean binary-indep binary-arch binary install configure |