| #!/usr/bin/make -f |
| # -*- makefile -*- |
| # Sample debian/rules that uses debhelper. |
| # This file was originally written by Joey Hess and Craig Small. |
| # As a special exception, when this file is copied by dh-make into a |
| # dh-make output file, you may use that output file without restriction. |
| # This special exception was added by Craig Small in version 0.37 of dh-make. |
| |
| # Uncomment this to turn on verbose mode. |
| #export DH_VERBOSE=1 |
| |
| |
| EXTRA_CFLAGS:="$(shell dpkg-buildflags --get CFLAGS | sed -e 's/-O2//')" |
| EXTRA_LFLAGS:="$(shell dpkg-buildflags --get LDFLAGS) -Wl,-soname,libre.so" |
| |
| |
| configure: configure-stamp |
| configure-stamp: |
| dh_testdir |
| # Add here commands to configure the package. |
| |
| touch configure-stamp |
| |
| build: build-stamp |
| build-stamp: configure-stamp |
| dh_testdir |
| |
| # Add here commands to compile the package. |
| $(MAKE) RELEASE=1 \ |
| EXTRA_CFLAGS=$(EXTRA_CFLAGS) \ |
| EXTRA_LFLAGS=$(EXTRA_LFLAGS) |
| |
| touch $@ |
| |
| clean: |
| dh_testdir |
| dh_testroot |
| rm -f build-stamp configure-stamp |
| |
| # Add here commands to clean up after the build process. |
| $(MAKE) clean |
| |
| dh_clean |
| |
| install: build |
| dh_testdir |
| dh_testroot |
| dh_prep |
| dh_installdirs |
| |
| # Add here commands to install the package into debian/tmp |
| mkdir $(CURDIR)/debian/tmp |
| $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp |
| |
| dh_movefiles |
| |
| # Build architecture-independent files here. |
| binary-indep: build install |
| # We have nothing to do by default. |
| |
| # Build architecture-dependent files here. |
| binary-arch: build install |
| dh_testdir |
| dh_testroot |
| dh_installchangelogs |
| dh_installdocs |
| dh_installexamples |
| # dh_install |
| # dh_installmenu |
| # dh_installdebconf |
| # dh_installlogrotate |
| # dh_installemacsen |
| # dh_installpam |
| # dh_installmime |
| # dh_installinit |
| # dh_installcron |
| # dh_installinfo |
| dh_installman |
| dh_link |
| dh_strip |
| dh_compress |
| dh_fixperms |
| # dh_perl |
| # dh_python |
| dh_makeshlibs |
| dh_installdeb |
| dh_shlibdeps |
| dh_gencontrol |
| dh_md5sums |
| dh_builddeb |
| |
| build-arch: build |
| |
| build-indep: build |
| |
| binary: binary-indep binary-arch |
| .PHONY: build clean binary-indep binary-arch binary install configure |