blob: b480d4a6bc94573b4b614130fc2913b1036d061e [file] [log] [blame]
Adam Snaider13d48d92023-08-03 12:20:15 -07001diff --git a/bazel/copts.bzl b/bazel/copts.bzl
2index f63e39ee93..78fdb3ac61 100644
3--- a/bazel/copts.bzl
4+++ b/bazel/copts.bzl
5@@ -58,5 +58,5 @@ GRPC_LLVM_WARNING_FLAGS = [
6
7 GRPC_DEFAULT_COPTS = select({
8 "//:use_strict_warning": GRPC_LLVM_WARNING_FLAGS + ["-DUSE_STRICT_WARNING=1"],
9- "//conditions:default": [],
10+ "//conditions:default": ["-Wno-missing-constinit"],
11 })
12diff --git a/bazel/grpc_extra_deps.bzl b/bazel/grpc_extra_deps.bzl
13index 4d8afa3131..4241197815 100644
14--- a/bazel/grpc_extra_deps.bzl
15+++ b/bazel/grpc_extra_deps.bzl
16@@ -52,9 +52,9 @@ def grpc_extra_deps(ignore_version_differences = False):
17
18 api_dependencies()
19
20- go_rules_dependencies()
21- go_register_toolchains(version = "1.18")
22- gazelle_dependencies()
23+ #go_rules_dependencies()
24+ #go_register_toolchains(version = "1.18")
25+ #gazelle_dependencies()
26
27 # Pull-in the go 3rd party dependencies for protoc_gen_validate, which is
28 # needed for building C++ xDS protos