Update WPILib, roborio compilers, and CTRE Phoenix libraries
This borrows heavily from work that Ravago did to initially get this
stuff working.
Tested rudimentary functionality on a test bench, ensured that we could:
* Enable the robot.
* Read joystick and button values.
* Switch between auto and teleop modes.
* Read sensor values (encoder, absolute encoder, potentiometer).
* Read PDP values.
* Drive PWM motors.
* Drive CANivore motors.
Non-WPILib changes are made to accommodate the upgrade roborio
compiler's improved pickiness.
Merge commit '125aac16d9bf03c833ffa18de2f113a33758a4b8' into HEAD
Change-Id: I8648956fb7517b2d784bf58e0a236742af7a306a
Signed-off-by: James Kuszmaul <jabukuszmaul+collab@gmail.com>
diff --git a/debian/fts.patch b/debian/fts.patch
index 7357940..ff0c8d6 100644
--- a/debian/fts.patch
+++ b/debian/fts.patch
@@ -1,5 +1,5 @@
---- arm-frc2020-linux-gnueabi/usr/include/fts.h
-+++ arm-frc2020-linux-gnueabi/usr/include/fts.h
+--- arm-nilrt-linux-gnueabi/usr/include/fts.h
++++ arm-nilrt-linux-gnueabi/sysroot/usr/include/fts.h
@@ -193,7 +193,7 @@ FTS *__REDIRECT (fts_open, (char * const *, int,
int (*)(const FTSENT **, const FTSENT **)),
fts64_open);