Provide Python 3 matplotlib
Once I get around to making numpy/scipy imported for Python 3, I'll
probably upgrade everything to Python 3 and drop Python 2 support from
the codebase, but I don't feel like doing that quite yet.
Change-Id: I164c8fbb3ce922a83b56e46f5cc432004c3a989c
diff --git a/debian/matplotlib_init.patch b/debian/matplotlib_init.patch
index 0106b64..e547108 100644
--- a/debian/matplotlib_init.patch
+++ b/debian/matplotlib_init.patch
@@ -18,7 +18,7 @@
+os.environ['MATPLOTLIBDATA'] = \
+ os.path.join( \
+ _matplotlib_base,
-+ "usr", "share", "matplotlib", "mpl-data")
++ "..", "usr", "share", "matplotlib", "mpl-data")
+# Avoid reading /etc/matplotlib in all cases. Matplotlib is pretty happy to
+# escape the sandbox by using absolute paths.
+os.environ['MATPLOTLIBRC'] = os.environ['MATPLOTLIBDATA']
@@ -29,7 +29,7 @@
+
+# Tell Tcl where to find the sandboxed version. Otherwise, it will try using
+# one from the host system, even if that's an incompatible version.
-+os.environ['TCL_LIBRARY'] = os.path.join(_matplotlib_base, 'usr', 'share',
++os.environ['TCL_LIBRARY'] = os.path.join(_matplotlib_base, '..', 'usr', 'share',
+ 'tcltk', 'tcl8.6')
+
try: