Use config found in SortLogs instead of random log files
This both gives us a single Configuration object to use for all
matching configuration, and also gives us an abstraction to use when we
move the config out of the top of each log file and into a separate
file.
While we are here, expose name from the log file header as well. This
removes the last user of the raw LogFileHeader from logger.
Change-Id: I0c99d64f9a7222e17100650cdf4b018ae224887a
diff --git a/debian/boringssl.patch b/debian/boringssl.patch
new file mode 100644
index 0000000..ceae8bc
--- /dev/null
+++ b/debian/boringssl.patch
@@ -0,0 +1,78 @@
+diff --git a/BUILD b/BUILD
+index cba9ccb1d..7890c88e6 100644
+--- a/BUILD
++++ b/BUILD
+@@ -25,6 +25,8 @@ load(
+ "crypto_sources",
+ "crypto_sources_linux_x86_64",
+ "crypto_sources_linux_ppc64le",
++ "crypto_sources_linux_aarch64",
++ "crypto_sources_linux_arm",
+ "crypto_sources_mac_x86_64",
+ "fips_fragments",
+ "ssl_headers",
+@@ -36,7 +38,17 @@ load(
+
+ config_setting(
+ name = "linux_x86_64",
+- values = {"cpu": "k8"},
++ constraint_values = ["@platforms//cpu:x86_64"],
++)
++
++config_setting(
++ name = "linux_aarch64",
++ constraint_values = ["@platforms//cpu:aarch64"],
++)
++
++config_setting(
++ name = "linux_arm",
++ constraint_values = ["@platforms//cpu:armv7"],
+ )
+
+ config_setting(
+@@ -76,6 +88,9 @@ posix_copts = [
+ "-Wwrite-strings",
+ "-Wshadow",
+ "-fno-common",
++ "-Wno-cast-qual",
++ "-Wno-cast-align",
++ "-Wno-unused-parameter",
+
+ # Modern build environments should be able to set this to use atomic
+ # operations for reference counting rather than locks. However, it's
+@@ -86,6 +101,8 @@ posix_copts = [
+ boringssl_copts = select({
+ ":linux_x86_64": posix_copts,
+ ":linux_ppc64le": posix_copts,
++ ":linux_arm": posix_copts,
++ ":linux_aarch64": posix_copts,
+ ":mac_x86_64": posix_copts,
+ ":windows_x86_64": [
+ "-DWIN32_LEAN_AND_MEAN",
+@@ -97,6 +114,8 @@ boringssl_copts = select({
+ crypto_sources_asm = select({
+ ":linux_x86_64": crypto_sources_linux_x86_64,
+ ":linux_ppc64le": crypto_sources_linux_ppc64le,
++ ":linux_arm": crypto_sources_linux_arm,
++ ":linux_aarch64": crypto_sources_linux_aarch64,
+ ":mac_x86_64": crypto_sources_mac_x86_64,
+ "//conditions:default": [],
+ })
+@@ -112,6 +131,8 @@ posix_copts_c11 = [
+ boringssl_copts_c11 = boringssl_copts + select({
+ ":linux_x86_64": posix_copts_c11,
+ ":linux_ppc64le": posix_copts_c11,
++ ":linux_arm": posix_copts_c11,
++ ":linux_aarch64": posix_copts_c11,
+ ":mac_x86_64": posix_copts_c11,
+ "//conditions:default": [],
+ })
+@@ -125,6 +146,8 @@ posix_copts_cxx = [
+ boringssl_copts_cxx = boringssl_copts + select({
+ ":linux_x86_64": posix_copts_cxx,
+ ":linux_ppc64le": posix_copts_cxx,
++ ":linux_arm": posix_copts_cxx,
++ ":linux_aarch64": posix_copts_cxx,
+ ":mac_x86_64": posix_copts_cxx,
+ "//conditions:default": [],
+ })